Обновление Zabbix c 4.0 до 4.4 на Debian 8

Заметка по обновлению zabbix-server и zabbix-agent. Мой конкретный случай это с версии 4.0 на 4.4, ОС Debian 8.

Принцип обновления один. Если у вас отличается ОС или версии ПО, то открываем официальный мануал и следуем понятным инструкциям — https://www.zabbix.com/documentation/current/ru/manual/installation/upgrade.

Перед началом работ я отключаю отправку оповещений триггеров.

Мой список команд:

service zabbix-server stop 
service zabbix-agent stop

cp -r /var/lib/mysql /opt/zabbix-backup/
cp /etc/zabbix/zabbix_server.conf /opt/zabbix-backup/
cp /etc/apache2/conf-enabled/zabbix.conf /opt/zabbix-backup/

cp -R /usr/share/zabbix/ /opt/zabbix-backup/
cp -R /usr/share/doc/zabbix-* /opt/zabbix-backup/

rm -Rf /etc/apt/sources.list.d/zabbix.list

wget https://repo.zabbix.com/zabbix/4.3/debian/pool/main/z/zabbix-release/zabbix-release_4.3-1+jessie_all.deb

dpkg -i zabbix-release_4.2-1+jessie_all.deb

apt-get update

apt-get install --only-upgrade zabbix-server-mysql zabbix-frontend-php zabbix-agent

service zabbix-server start
service zabbix-agent start

tail -f /var/log/zabbix/zabbix_server.log - наблюдать за обновлением базы

Не забывать включить отправку оповещений триггеров после того, как убедились, что всё работает.

В данном случае я обновлялся до 4.3, но почему-то получилось 4.4.0alpha2.


Ещё с обновления версии 3.4 осталась у меня такая заметка по ошибке:

Cannot find module (IF-MIB): At line 1 in (none)
Cannot find module (SNMPv2-MIB): At line 1 in (none)
Cannot find module (HOST-RESOURCES-MIB): At line 1 in (none)
Cannot find module (IF-MIB): At line 1 in (none)

Решил так:

aptitude install snmp-mibs-downloader 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *